Stránka 1 z 2

TrainController (nejen) a kompatibilita

PříspěvekNapsal: čtv 31 pro, 2015 10:33 am
od mpinta
Vážení kolegové,
technologie stále uhánějí vpřed mílovými kroky, a tak si myslím, že je vhodná doba probrat některá témata trochu detailněji.

Na zodpovězení existují i další zdroje, především výrobci, prodejci (málokteří) nebo jiná (zahraniční) diskuzní fóra. Než začnu zkoušet a pátrat dále, považuji za nejjednodušší, obrátit se sem, na naši domácí diskuzi.

Stále častěji ke mně dorážejí dotazy, související s kompatibilitou různých systémů, softwaru a hardwaru.
Jako ústřední dotaz bych viděl ...

- Lenz centrála LZV100, LZ100
- Lenz 23151 interface (IF)
- Windows 10 32 i 64bit
- TC Gold/Silver 7,8.


Funguje to v této sestavě? Provozuje to tak někdo? Kde vzít ovladač (driver) pro IF?

Všimněte si, že je popsán celý řetězec, tedy centrála, interfejs, operační systém (OS), TrainController. Nemá smysl uvádět, že na Win 10 TrainController funguje. Vždy záleží na použitých HW komponentech, především na IF a jeho ovladači (driveru).

To by pro začátek stačilo, snad se časem dopracujeme k požadovaným závěrům.

Re: TrainController a kompatibilita

PříspěvekNapsal: čtv 31 pro, 2015 11:06 am
od BohousP
Martine,
já bych jako klíčovou viděl otázku spolupráce Interface 23151 a Windows 10.
Samotné centrále je lautr jedno, jestli používáš Windows 10 nebo něco jiného, komunikuje pouze prostřednictvím inteface.
Že Traincontroller běží (byť zatím oficiálně nepodporován) na Windows 10 už bylo popsáno http://diskuze.modely.biz/viewtopic.php?f=26&t=4766&p=187666&hilit=+Windows+10+#p187666. Obávám se, že Mr. Freiwald si oficiální podporu nechá až do TC 9 a nechá si to zaplatit formou upgrade.
Takž bych tu otázku zúžil na interface a Windows 10. Google na dotaz "Lenz 23151 interface windows 10 driver" vyhodí tuto stránku: https://www.google.com/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=Lenz+23151+interface+windows+10+driver, kde se už něco dá dohledat, ale nejčastěji jsou to buď staré dokumenty v W7, nebo W8, v lepším případě diskusní fóra.

Dalším proklikáváním jsem se dostal až na https://groups.yahoo.com/neo/groups/DigitalPlusByLenz/conversations/messages/18394, ale to je o IP připojení, ne USB. Takže slepá ulička. Možná někde pod jiným odkazem bude lepší cesta ...
Podle mne by stálo zato vyzkoušet driver podle http://railway.zone/post/Lenz-LI-USB-64-bit-drivers-for-Windows-8, byť se jedná o osmičkový. Ale já Lenze nepoužívám, takže to dělat neplánuji.

Re: TrainController a kompatibilita

PříspěvekNapsal: čtv 31 pro, 2015 4:01 pm
od mpinta
BohousP píše:Martine,
já bych jako klíčovou viděl otázku spolupráce Interface 23151 a Windows 10.
To jistě, ovšem to vyzkouším, cca během měsíce, sám (doufám). Tady jsem jen chtěl zjistit, zda to někdo už tak používá. Otázka driveru mi totiž jasná není. Instalační CD od Lenze mám všechny tři, pro LI101F, pro 23150 i pro nejnovější 23151. Každé je uděláno jinak. Poslední, pro 23151 obsahuje pouze jediný driver, který je zřejmě použitelný pro Windows 2000/XP/Server2003/Vista/Server2008/7 - 32/64bit Sections. Win8 či Win10 ještě neexistovaly. Ani nevím, zda tedy tento driver chodí i pro Win8. To ale zkoušet nehodlám.

No, a pak jsou tu další zařízení, jako třeba Roco multiMaus, Z(z)21, NanoX (a různé H-centrály), příp. nová Digikejs DR5000 a pod.

Osobně to nepotřebuji, ale bylo by přece pěkné, mít informace napříč všemi verzemi pohromadě v přehledné tabulce, co a jak lze zapojit, kde vzít ovladač atd.

Všechno sám vyzkoušet nemůžu. Sice nemám rád převzaté informace, ale tady to asi jinak nepůjde. Právě proto odmítám příspěvky typu "takto by to určitě mělo jít". Ty správné zní "takto to používám a funguje to".

Re: TrainController a kompatibilita

PříspěvekNapsal: pát 01 led, 2016 12:37 pm
od jamik22
Provozuji -
Lenz centrála LZV100, LH100 verze SW 3.5
Lenz 23151 interface
Windows 10 64bit
TC Gold v7 ostrý , v8 demo
propojení na PC Ethernet kabelem přes Wifi router kam připojuji iPhone s ToouchCab.
takto vše bez problému
Problém je s USB drivery pro Win7 a Win 8 v 64 bit versi. Kdysi jsem našel na webu modifikované drivery pro Win7 64 bit systém. Byly opečovány aby se tvářily jako podepsané od LENZe. Ty mi fungovaly. Tato verse není funkční pro Win8 a Win10. Pro sebe jsem to vyřešil Ethernetem. Pak se na zmiňované Yahoo konferenci objevily nově modifikované verse pro Win8/Win10, ale ty už jsem netestoval.
Pokud by někdo chtěl, link už nemám, ale mám je stažené a mohu i s návodem poslat přes mail

Re: TrainController a kompatibilita

PříspěvekNapsal: pon 04 led, 2016 3:16 pm
od mpinta
Na stránky LokoPin jsem nahodil článek http://lokopin.wz.cz/body.php/digital/kompatibilita.htm
Jak bych vás jen přiměl ke spolupráci ?
Hoši, do toho, děláte to pro ostatní !!!

Re: TrainController a kompatibilita

PříspěvekNapsal: úte 05 led, 2016 10:57 am
od Michal Dalecký
U mě: LZV100, LH100, USB Lenz 23150, windows 10 32-bit a TC Gold 7.0 a vše pracuje jak má. OS si bez problémů nainstaloval ovladač pro rozhraní.

Re: TrainController a kompatibilita

PříspěvekNapsal: stř 06 led, 2016 10:43 am
od mpinta
Pěkně se to rozjelo, informace ke mně docházejí nejen zde, ale i mailem a přes Skype.
Jen jsem trochu netušil, že mi ta tabulka dá tolik zabrat. No, hlavně aby to bylo k něčemu.

Ještě poznámku ...
Testery, tedy kolegy poskytující informace, uvádím vždy s nějakým kontaktem, obvykle mailem. Je to z toho důvodu, aby byla možnost se s uživatelem určité používané varianty spojit a dořešit případné detaily.
Zřejmě jsem měl požádat o svolení předem. Nestalo se, a jestliže jsem se někoho dotkl, omlouvám se.
Pokud by si někdo výslovně nepřál, abych kontakt takto zveřejňoval, ať se laskavě ozve, upravím (odmažu).

Každopádně už teď velice děkuji všem, kteří laskavě poskytli potřebné údaje :!: :!: :!:

Re: TrainController (nejen) a kompatibilita

PříspěvekNapsal: stř 06 led, 2016 2:16 pm
od Jirka_US
Vyzkousene kombinace:
Digitrax DCS50 + LocoBuffer USB + PC
- TC Gold V8.0 + W7
- TC Gold V8.0 + XP
- TC 5.8 + Windows ME
- JMRI 3.7.4 + W7
- JMRI 4.2.1 + XP + WiThrottle (iOS) + Engine Driver (Android)
- JMRI 2.8 + Windows ME

Digitrax DCS50 + LocoBuffer USB + Raspberry PI
- JMRI 3.10 + Raspbian (Linux) + WiThrottle (iOS) + Engine Driver (Android)

Link na prislusny ovladac pro LocoBuffer:
http://www.rr-cirkits.com/

Re: TrainController (nejen) a kompatibilita

PříspěvekNapsal: stř 06 led, 2016 2:33 pm
od HonzaM
Vyzkousene kombinace:
Digitrax DCS200 + LocoBuffer USB + PC
- TC Gold V8.0 + W7.0

Digitrax DCS200 + Digitrax PR3+ PC
- TC Gold V8.0 + W7.0

Digitrax DB150 + LocoBuffer USB + PC
- TC Gold V8.0 + W7.0

Digitrax DB150 + Digitrax PR3 + PC
- TC Gold V8.0 + W7.0

Re: TrainController (nejen) a kompatibilita

PříspěvekNapsal: stř 06 led, 2016 3:21 pm
od mpinta
To: HonzaM, Jirka_US, ale i další...
Je mi líto, ale musíte to psát v tom formátu, jak je udělána ta tabulka v článku.

SW: 8 G
Centrála: CENTRALA
Interface: IF
OS: WIN
Driver/Ovladač: DRIVER
Tester: JM_PRI_MAIL
Poznámka: POZNAMKA

Stačí i takto jednoduše, textově, může to být i v excelu, html, PDF ... ale musím vědět, co do jakého sloupce napsat.

Pochopte, že u zařízení, které neznám, nemusím vědět, co je centrála, co interface atd.
Pak to jen odhadnu, či pracně vyhledávám, a když je to špatně, hned dostávám další SZ a maily a musít to editovat.
DĚKUJI.
P.S. To: HonzaM, Jirka_US Teď už to sem znovu nepište, pošlete to na mail mpinta(zavináč)seznam.cz nebo SZ.
A u OS WIN doplňte 32/64, pokud možno...

HonzaM píše:Vyzkousene kombinace:
Digitrax DCS200 + LocoBuffer USB + PC
- TC Gold V8.0 + W7.0- TC Gold V8.0 + W7.0 ...
To nemá drivery? Nebo se nainstalují aut. z Win7 ?

Re: TrainController (nejen) a kompatibilita

PříspěvekNapsal: čtv 07 led, 2016 8:29 am
od BohousP
Doplním informaci o přehledu rozhraní od DIGI-CZ http://www.digi-cz.info/prehled-rozhrani-k-pc/, popis verzí je na http://www.digi-cz.info/gen-li-usb-maxi/#HSI88.

Re: TrainController (nejen) a kompatibilita

PříspěvekNapsal: ned 10 led, 2016 12:09 pm
od mpinta
Článek dospěl do určité podoby. Doufám, že vám bude k užitku, neboť "tvořit" na zchátralém železe a špatně fungujících XPéčkách, to je běs.
Uspořádání, třídění atd., to vše jsem upravil podle vašich požadavků. Jistě by to šlo udělat lépe, ale všem se zavděčit nelze, a snad to i tak poslouží nejen začátečníkům, ale i experimentátorům.
Na nějaká data ještě čekám, především od sebe, ta budou ještě doplněna. Pokud naleznete chyby, ozvěte se.

Re: TrainController (nejen) a kompatibilita

PříspěvekNapsal: ned 10 led, 2016 12:30 pm
od HonzaM
Jen doplnění - pokud skutečně bude centrála Digikeijs splňovat co se uvádí na stránkách této firmy, pak bude interface přmo v centrále DR5000 a výrobce uvádí, že je s TrainControllerem kompatibilní. Počítač se tedy připojí přímo k centrále. Je ovšem otázkou, zda a kdy bude tato centrála na trhu, první informace na webu byla, že to bude v polovině prosince 2015, potom 18.1.2016, teď tam je jen "leden 2016".

Re: TrainController (nejen) a kompatibilita

PříspěvekNapsal: ned 10 led, 2016 12:47 pm
od komori
Martine, smekám před tvojí perfektní tabulkou a děkuji,
z této tabulky jsem pochopil několik nových věcí.
Blahopřeji.

Re: TrainController (nejen) a kompatibilita

PříspěvekNapsal: ned 10 led, 2016 12:56 pm
od mpinta
HonzaM píše:... pokud skutečně bude centrála Digikeijs splňovat co se uvádí na stránkách této firmy ...
A proč by nesplňovala? Kritizovat můžeme, ale podle skutečnosti, ne podle předpokladů.

HonzaM píše:... Je ovšem otázkou, zda a kdy bude tato centála na trhu ...
A proč by nebyla? V lednu, nebo později. Jsme zvyklí na jinačí zpoždění.

Pak ovšem jistě přibudou další varianty a tedy záznamy do tabulky.

A mimochodem, Honzo, na centrálu Digikeijs DR5000 je jiné vlákno. Co to sem pleteš ? :!: :!: :!: